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P

 ython เปนหนึ่งในภาษาคอมพิวเตอรที่ไดรับความนิยมสูงสุดในปจจุบัน ซึ่งนอกจากจะงายตอการเรียนรู 

 แลว ยังสามารถนําไปประยุกตใชงานไดหลากหลายรูปแบบ โดยเนื้อหาในบทนี้จะกลาวถึงการติดตั้ง 

เครื+องมือสําหรับการเขียนโคด พรอมทั้งการต้ังคาที่จําเปนตองทราบในเบื้องตน ซึ่งผูอานควรใชงานใหเกิด 

ความคุนเคยในระดับหนึ่งกอน ทั้งนี้ก็เพื+อประโยชนตอการเรียนรูในบทตอ ๆ  ไป

เกี่ยวกับภาษา Python 
ภาษาไพธอน (Python Language) สรางขึ้นเมื+อป ค.ศ. 1994 โดย

โปรแกรมเมอรชาวดัตชที่ชื+อ Guido van Rossum ดวยพื้นฐานจากหลายภาษา

รวมกัน เชน C, ABC, Modular-3, Algol-68, SmallTalk, Unix Shell เปนตน 

เพื+อใหเปนภาษาคอมพิวเตอรที่เรียนรูไดงาย ไมมีกฎเกณฑหรือหลักไวยากรณที่ 

ซับซอน และสามารถนําไปใชบนระบบปฏิบัติการท่ีแตกตางกันได ปจจุบันไพธอน 

จดัอยูในกลุม Top-5 ของภาษาคอมพวิเตอรทีม่ผีูใชงานมากท่ีสดุ จงึเปนสิง่ทีย่นืยนั

ถึงความสําเร็จไดเปนอยางดี และนอกจากนี้ก็ยังมีลักษณะที่น�าสนใจอื+น ๆ  คือ

 Free - สามารถนํามาใชงานไดฟรี โดยไมมีคาใชจายหรือเงื+อนไขใด ๆ

 Easy to Use & Learn - มีโครงสรางทางภาษาที่เรียบงาย และสามารถเรียนรูไดเร็ว จึงเหมาะ 

อยางยิ่งสําหรับผูเริ่มตนศึกษาการเขียนโปรแกรม

Python, VS Code  
และ Jupyter
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 General Purpose - ไพธอนเปนภาษาแบบเอนกประสงคที่เราสามารถใชในการโปรแกรมได 

หลากหลายรปูแบบ นบัตัง้แตแอปพลเิคชนัทัว่ไป เว็บแอปพลเิคชนั การเขียนโปรแกรมสําหรบัเครือขาย  

หรือการคํานวณทางวิทยาศาสตร เปนตน 

 Portable - สามารถนาํโปรแกรมท่ีเขยีนดวยไพธอนบนระบบปฏบิตักิารหน่ึง ไปใชบนอกีระบบหนึง่ได 

เชน เราอาจเขียนโปรแกรมบน Windows แลวนําไปใชงานบนเครื+อง Mac หรือ Linux เปนตน หรือ

เรียกวาการทํางานขามแพลตฟอรม (Platform) นั่นเอง

 Open Source - ไพธอนเปนภาษาแบบเปดเผย Source Code ภายใตลขิสทิธิข์อง Python Software 

Foundation ดงัน้ัน จึงมกีลุมอาสาสมคัรเขารวมพฒันาอยางมากมาย ชวยใหภาษามีววิฒันาการอยาง

ตอเนื+อง

 Functional & OOP - สามารถเลอืกเขยีนโปรแกรมไดทัง้แบบ Functional และแบบ Object-Oriented

 GUI Programming - ไพธอนสนบัสนุนการเขยีนโปรแกรมแบบ Graphic User Interface เพื+อตดิตอ

และโตตอบกับผูใชแบบกราฟก ซึ่งสามารถนําไปใชงานบนระบบปฏิบัติการที่แตกตางกันได

 Databases - ไพธอนมีไลบรารีที่สนับสนุนการเชื+อมตอกับโปรแกรมฐานขอมูลหลัก ๆ  เกือบทั้งหมด

 Automatic Memory Management - ภาษาไพธอนมีกลไกจัดการหน�วยความจําแบบอัตโนมัติ จึง

ชวยลดขอผิดพลาดจากการเกิดปญหา Memory Leak และสงผลใหโปรแกรมทํางานไดอยางคงทน

 Large Community & Support - ภาษาไพธอนมีชุมชนหรือกลุมผูใชขนาดใหญ ที่พรอมใหการ

สนับสนุนและชวยเหลือเมื+อเราเกิดปญหา

 Support Libraries - นอกจากไลบรารีแบบ Built-in ที่มากับภาษาไพธอนเองแลว เราสามารถนํา

ไลบรารีจากภายนอก หรือ Third-Party Libraries เขามาเสริมการทํางานไดอีกดวย จึงเกิดทางเลือก

ในการพัฒนาแอปพลิเคชันที่หลากหลายยิ่งขึ้น

การติดตั้งภาษา Python
กอนที่เราจะสามารถทดสอบการทํางานตาง ๆ  ได จําเปนตองติดตั้งตัวประมวลผลของภาษาไพธอนลงไป

กอน โดยมีขั้นตอนที่สําคัญดังนี้
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1. เราสามารถดาวนโหลดชุดติดตั้งไดจากเว็บไซต https://www.python.org/downloads

2. หลังจากดาวนโหลดเสร็จ ก็ดับเบิลคลิกไฟลที่ไดมา เมื+อปรากฏหนาจอที่แสดงฟเจอร (Feature)  

ในการติดตั้ง สิ่งที่ควรเลือกคือ

1) Add Python X.XX (หมายเลขเวอรชัน) to PATH

2) คลิกที่กรอบ Install Now เพื+อเลือกติดตั้งองคประกอบที่จําเปนตอการใชงานทั่ว ๆ  ไปทั้งหมด 

1

2
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3. หลังจากนั้น จะเขาสูขั้นตอนการติดตั้ง ก็ใหเรารอจนกวาจะเสร็จสิ้น

หลังจากติดตั้งภาษาไพธอนลงไปแลว สิ่งที่เราตองพิจารณาในลําดับถัดไปคือ การเลือกเครื+องมือในการ

เขียนโคด ซ่ึงมีตัวเลือกคอนขางมาก และตางก็มีขอดีขอเสียที่แตกตางกัน สําหรับในหนังสือเลมนี้ ผูเขียนจะ

เลือกใช Jupyter บน VS Code เปนหลัก ดังรายละเอียดที่จะกลาวถึงในหัวขอตอ ๆ  ไป

การใชงาน Visual Studio Code (VS Code)
Visual Studio Code หรือโดยทั่วไปเรามักเรียกส้ัน ๆ  วา VS Code เปนโปรแกรมประเภท IDE  

(Integrated Development Environment) ที่ Microsoft สรางขึ้นมาสําหรับใชในการเขียนโคดทั่ว ๆ  ไป และ

ไดรับความนิยมสูงสุดในปจจุบัน เนื+องจากมีลักษณะที่โดดเดนหลายประการ เชน ใหใชงานฟรี รองรับการเขียน

โคดไดหลายภาษา และที่สําคัญคือ มีสวนเสริมการทํางานใหเลือกใชมากมาย แมในหนังสือเลมนี้จะเนนการใช 

Jupyter เปนหลัก แตก็ตองทํางานอยูบนพื้นฐานของ VS Code (ใชงานรวมกัน) ดังนั้น จึงจําเปนตองรูจักวิธี

การใชงานบางอยางเกี่ยวกับ VS Code เอาไวลวงหนา โดยสิ่งที่เราควรรูในเบื้องตนมีดังนี้
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การติดตั้ง VS Code
สําหรับการติดตั้ง VS Code ลงในเครื+องที่เราจะใชงาน มีขั้นตอนโดยสังเขปคือ

1. สามารถดาวนโหลดชุดติดตั้งไดที่ https://code.visualstudio.com/download

2. หลังจากดาวนโหลดเสร็จ ใหดับเบิลคลิกไฟลติดตั้งที่ไดมา จากนั้นในหนาจอถัดไป ก็ยอมรับเงื+อนไข

แลวคลิกปุม Next (ดังภาพถัดไป ดานซายมือ)

3. ขั้นตอนตอไป จะมีออปชันใหเลือก ก็แนะนําใหเลือกทั้งหมด แลวคลิกปุม Next

1

2

1

2

4. ตอจากนั้น คลิกปุม Install เพื+อเริ่มการติดตั้งไฟล จากนั้นก็รอจนกวาจะแลวเสร็จ
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หนาจอ Welcome (Get Started)
เมื+อเราเปดเขาสู VS Code ตามปกติ จะปรากฏหนาจอ Welcome (หรือ Get Started) เปนอันดับแรก 

ซึ่งลักษณะที่สําคัญเกี่ยวกับหนาจอนี้คือ

 อาจมีการแจงขอมูลขาวสารที่น�าสนใจเกี่ยวกับ VS Code

 มีลิงกสําหรับใหเราคลิกเพื+อเปดไฟลหรือโฟลเดอรเปาหมายที่ตองการไดอีกหนึ่งวิธี นอกเหนือจาก

การเลือกที่เมนู

 มลีงิกทีแ่สดงประวตักิารเปดโฟลเดอรทีเ่ราเขาสู VS Code ในครัง้กอน ๆ  ซึง่หากมโีฟลเดอรเปาหมาย

ที่เราตองการรวมอยูดวย ก็สามารถคลิกเปดจากตรงนี้ไดทันที

หากเราตองการปดหนาจอนี้ ก็คลิกปุม X ที่แท็บดานบน หรือหากไมตองการใหปรากฏหนา Welcome 

(Get Started) ตอไปอีก ก็ใหเราเอาเครื+องหมายถูกตรงตัวเลือก Show welcome page on startup ที่บริเวณ

ขอบดานลางออก หรือหลังจากปดไปแลว หากเราตองการใหหนาจอ Welcome กลับมาแสดงอีกครั้ง ก็ใหเลือก

ที่เมนู Help > Get Started 
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การเลือกรูปแบบสี (Theme)
ตามปกต ิVS Code จะเลอืกธมี (Theme) เปนสดีาํ (Dark) เอาไวลวงหนา ซึง่หากเราชอบแบบนี ้กไ็มจาํเปน 

ตองปรับเปลี่ยนก็ได แตถาเราตองการสีสันในรูปแบบอื+น ก็สามารถเปลี่ยนแปลงได ซึ่ง VS Code มีตัวเลือกอยู

จํานวนหนึ่ง โดยใชขั้นตอนดังนี้

1. ที่มุมลางขวาของโปรแกรม VS Code ใหคลิกที่ไอคอน Manage (รูปเฟอง)

2. เลือกที่เมนู Color Theme

จากนัน้จะปรากฏรายชื+อสใีหเลอืก ถาเรายงัไมทราบวาแตละสมีลีกัษณะเปนยงัไง กอ็าจลองเลอืกดกูอนกไ็ด 

ถาไมถกูใจกค็อยเลอืกสใีหม สาํหรบัทีใ่ชประกอบในหนงัสือเลมนี ้ผูเขยีนจะเลอืกธมีสแีบบ Light (Visual Studio)

1

2

3

การปรับเปลี่ยนฟอนต
ฟอนต (Font: ในที่นี้คือตัวอักษรที่ใชเขียนโคดและแสดงผลลัพธ) ที่ VS Code กําหนดเอาไวลวงหนา 

แมจะเปนรูปแบบมาตรฐานที่นิยมใชงานกันทั่วไป แตหากตองการใชฟอนตที่เราถูกใจ ก็สามารถเปลี่ยนแปลงได

ดวยขั้นตอนดังตอไปนี้
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1. ที่มุมลางขวาของโปรแกรม VS Code ใหคลิกที่ไอคอน Manage (รูปเฟอง)

2. เลือกที่เมนู Settings

3. คลิกแท็บ Text Editor

4. คลิกแท็ก Font

5. กําหนดชื+อฟอนตลงในชอง Font Family ซึ่งตามปกติ จะมีฟอนตเดิมที่ VS Code กําหนดไวใหลวง

หนา หากเราตองการเปลีย่นไปใชชนดิอื+น ควรเพิม่ชื+อฟอนตไวขางหนาฟอนตเดมิ (ชื+อทีอ่ยูกอน จะถกู 

พิจารณากอน และไมแนะนําใหลบชื+อฟอนตเดิมออก) โดยคั่นดวยเครื+องหมาย , และถาชื+อฟอนต

ชนดินัน้มชีองวาง ใหเขยีนไวในเครื+องหมาย ' ' ซึง่ชื+อฟอนตทีร่ะบ ุตองถกูตดิตัง้เอาไวในเครื+องนัน้อยู

กอนแลว (การติดตั้งฟอนต ใหคัดลอกไฟลของฟอนตไปไวที่ C:\Windows\Fonts แลวเริ่มโปรแกรม

ที่จะใชฟอนตใหม)

6. ถาตองการกําหนดขนาด ก็ระบุ

ตวัเลขลงในชอง Font Size และ

เมื+อปดหนาจอ Setting ฟอนตที่

ตั้งคาเอาไว ก็จะมีผลทันที

นอกจากนี้ ยังมีเทคนิคเพิ่มเติมอีกอยางคือ การยอหรือขยาย (Zoom) ขนาดของฟอนตในโปรแกรม VS 

Code ใหใหญขึ้นหรือเล็กลง ซึ่งกรณีนี้ จะมีผลกับทั้งโคด เมนู และขอความอื+น ๆ  ท้ังหมดบน VS Code โดย

ใชวิธีการงาย ๆ  คือ

2
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 หากตองการขยายขนาดเพิ่มขึ้น (Zoom In: คลายกับการเขาไปมองใกล ๆ  ซึ่งจะเห็นขนาดที่ใหญขึ้น) 

ใหกดคียบอรดปุม <Ctrl => หรือเลือกเมนู View > Appearance > Zoom In ซึ่งหากทําซํ้าเชนนี้

อีก ขนาดของฟอนตจะเพิ่มขึ้น 1 ระดับไปเรื+อย ๆ

 หากตองการลดขนาดใหเล็กลง (Zoom Out: คลายกับการออกมามองไกล ๆ  ซ่ึงเราจะเห็นขนาดที่ 

เล็กลง) ใหกดคียบอรดปุม <Ctrl -> หรือเลือกเมนู View > Appearance > Zoom Out ซ่ึงหาก

ทําซํ้าเชนนี้อีก ขนาดของฟอนตจะลดลง 1 ระดับไปเรื+อย ๆ

การเขียนโคด Python บน VS Code โดยตรง
แมในหนังสือเลมนี้จะเนนการเขียนโคดบน Jupyter ในรูปแบบสวนเสริมของ VS Code ดังที่จะกลาวถึง 

ในหัวขอถัดไป แตเราก็ควรมีพื้นฐานการเขียนโคดบน Editor ของ VS Code เอาไวบาง ซึ่งอาจตองนําไปใชงาน 

ในบางโอกาส ดังนั้น จึงจะแนะนําแนวทางไวพอสังเขป แตอยางไรก็ตาม VS Code มีเพียงหนาที่เกี่ยวกับ 

การเขียนโคดเทาน้ัน แตการประมวลผลคําสั่ง (Compile) เปนหนาที่ของตัวแปลภาษาไพธอน ดวยเหตุนี้  

เราจําเปนตองติดตั้งภาษาไพธอนเอาไวกอนแลว จึงจะทดสอบการทํางานได และหากเราติดตั้งภาษาไพธอน 

ดังที่กลาวไปในหัวขอกอนนี้ ก็สามารถใชงานไดเลย

จากภาพ เปนหลกัการโดยสงัเขปในการทาํงานของภาษาไพธอน กลาวคือ เราจะเขยีนโคดบน Editor ของ 

VS Code จากนั้น เมื+อสั่งรัน (Run) โคดจะถูกสงไปประมวลผลยังตัวแปลภาษาไพธอน แลวผลลัพธที่ไดจะถูก

สงกลับมาแสดงผลที่สวน Terminal ของ VS Code

สําหรับขั้นตอนการเขียนโคดบน VS Code มีแนวทางโดยสังเขปดังนี้

1. ตามหลกัการของ VS Code เราควรสรางโฟลเดอรสาํหรบัเกบ็ไฟลไวตางหาก ซึง่ในท่ีนีผู้เขยีนจะสราง

โฟลเดอรชื+อ python ไวที่ตําแหน�ง c:\python
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2. เมื+อเปดเขาสู VS Code ใหเปดโฟลเดอรที่ใชเก็บโคดไพธอนที่สรางเอาไว เชน เลือกที่เมนู File > 

Open Folder จากนั้น ก็เลือกโฟลเดอรดังกลาว (ในที่นี้คือ c:\python)

3. หลังจากนั้น ใหเราสรางไฟลเพิ่มเขามาใน

โฟลเดอร ดังนี้

1) คลิกที่ไอคอน New File

2) กําหนดชื+อไฟลลงไป โดยตองมีสวน

ขยายเปน .py เทานั้น

4. ตอไป ก็เขียนโคดภาษาไพธอนลงใน Editor ไดเลย แลวบันทึกการเปลี่ยนแปลง เชน กด <Ctrl + S>  

หรือเลือกจากเมนู File > Save

5. หากตองการรนั ใหคลกิทีปุ่มไอคอนหวัลกูศรตรงมุมขวาบน ซึง่ไอคอนนีจ้ะปรากฏเมื+อเราอยูในมุมมอง

การเขียนโคดภาษาไพธอนเทานั้น

6. หลงัการสัง่รนั หากโคดไมมขีอผดิพลาด ก็จะถกูสงไปประมวลผลยงัตวัแปลภาษาไพธอนแลวผลลพัธ

ที่ไดก็จะปรากฏที่ Terminal ดานลาง ดังหลักการที่กลาวมาแลว

หากเราจะทดสอบในกรณีอื+น ๆ  ถาไมจําเปนตองเก็บโคดเดิมเอาไว ก็สามารถลบทิ้ง แลวเขียนโคดใหม 

ลงไปแทนไดเลย แตหากตองการเกบ็โคดเดิมเอาไว เราตองสรางไฟลใหมเพิม่เขามาในโฟลเดอรดวยหลกัการเดมิ 

ทัง้หมด แลวเมื+อเลกิใชงาน ก็ควรปดโฟลเดอรโดยเลอืกทีเ่มน ูFile > Close Folder และในการใชงาน VS Code  

คราวตอไป ก็อาจทําแบบใดแบบหนึ่งดังนี้

1
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  วิธีที่ 1 เลือกเปดโฟลเดอรที่เก็บไฟลของโคดเอาไว เชน เลือกเมนู File > Open Folder จากนั้น

เลือกโฟลเดอรที่จัดเก็บโคดไพธอนเอาไว

  วิธีที่ 2 อาจเลือกเปดไฟลแบบเจาะจงก็ได เชน เลือกเมนู File > Open File จากนั้นเลือกไฟลที่

จัดเก็บโคดไพธอนเอาไว (.py) แลวเมื+อเลิกใชงาน ก็ควรปดไฟลโดยเลือกที่เมนู File > Close Editor

ในการเปดใชงาน VS Code ครั้งตอ ๆ  ไป ถามีรายชื+อโฟลเดอรหรือไฟลเปาหมาย ปรากฏบนหนาจอ 

Welcome (Get Started) ก็สามารถคลิกที่ลิงกเพื+อเปดจากตรงนั้นเลยก็ได

Jupyter สําหรับ VS Code
กรณีที่เราเริ่มตนศึกษาการเขียนโคด อาจมีเนื้อหาปลีกยอยหลายอยางที่เราจําเปนตองทดสอบอยูตลอด  

ซึ่งหากเราตองการนําโคดกลับมาใชงานใหม ก็ตองจัดเก็บโคดเหลานั้นแยกไวคนละไฟล ดังนั้น ถาเราทดสอบ 

100 ตัวอยาง ก็ตองสราง 100 ไฟล เปนตน นี่จึงกลายเปนความยุงยากอีกอยางหนึ่งของการเรียนรูในเบื้องตน

จากปญหาดังที่กลาวมา เราอาจเปลี่ยนมาเขียนโคดดวยเครื+องมืออีกแบบหนึ่ง ซึ่งสามารถจัดเก็บโคด 

การทดสอบปลกียอยหลาย ๆ  อัน รวมไวในไฟลเดยีวกนัได โดยเราเรียกเครื+องมอืนีว้า Jupyter Notebook (อาจ

เรียกสั้น ๆ  วา Jupyter) ซึ่งมีลักษณะที่น�าสนใจดังนี้
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 Jupyter จะแบงพื้นที่สําหรับการเขียนโคดออกเปนชอง ๆ  ซึ่งเรียกวาเซลล (Cell)

 ในไฟลเดียวกัน สามารถสรางไดมากกวา 1 เซลล

 เราสามารถเขียนโคดเพื+อทดสอบในแตละเรื+องโดยแยกไวคนละเซลล และสามารถรันเพื+อดูผลลัพธ

เฉพาะโคดที่อยูในเซลลใดเซลลหนึ่งไดเลย

ตามปกติ เราสามารถใช Jupyter ไดหลายแนวทาง เชน ติดตั้งผานชุด Anaconda หรือใชงานผาน 

Google Colab เปนตน แตวิธีเหลาน้ี จะใชงานในแบบเว็บแอปพลิเคชัน ซึ่งอาจมีขั้นตอนที่ยุงยากเล็กนอย

สําหรับผูเริ่มตน และนอกจากวิธีการดังกลาว ก็ยังมีทางเลือกใหเราสามารถนํา Jupyter มาใชรวมกับ VS Code 

ในรูปแบบของสวนเสริม (Extension) ไดเชนกัน โดยเราตองติดตั้งเพิ่มเติมลง VS Code ดังขั้นตอนตอไปนี้

1. ที่ VS Code ใหคลิกที่ไอคอน Extension ที่แถบดานซาย

2. พิมพคําวา Jupyter ลงในชองคนหา (ขณะนั้นตองเชื+อมตออินเทอรเน็ต)

3. ตามปกติ ผลการคนหาจะมีรายการที่ชื+อ Jupyter (ที่ผานการตรวจสอบจาก Microsoft แลว) และ

ถามีไอคอนรูปเฟองปรากฏที่กรอบรายการดังกลาว แสดงวา Jupyter ถูกติดตั้งเอาไวแลว ซึ่งเราไม

จําเปนตองทําอะไรตอ สามารถคลิกที่ไปไอคอน Extension (เชนเดียวกับขอ 1) เพื+อปดหนาจอการ

คนหาสวนเสริมไดเลย

2
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4. แตหากที่กรอบรายการ Jupyter (ผลการ

คนหา) ปรากฏปุมที่มีคําวา Install แสดง

วายังไมไดติดตั้ง Jupyter ก็ใหเราคลิกปุม

ดังกลาวเพื+อติดตั้งลงใน VS Code ไดเลย
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อยางไรก็ตาม Jupyter ก็เปนเพียงเครื+องมือในการเขียนโคดเชนเดียวกับ VS Code แตหนาที่ในการ

ประมวลผลคําสัง่ก็เปนของตวัแปลภาษาไพธอนอกีเชนกนั ดังนัน้ เราตองตดิตัง้ภาษาไพธอนเอาไวกอนแลวจงึจะ

รนัทดสอบ Jupyter ได โดยลกัษณะการทาํงานรวมกนัระหวาง VS Code กับ Jupyter และ Python เปนดงัภาพ

การสรางไฟลของ Jupyter
การใชงาน Jupyter ในแบบสวนเสริมของ VS Code นั้น เราตองสรางและเปดไฟลที่เปนรูปแบบของ 

Jupyter เครื+องมือตาง ๆ  จึงจะปรากฏใหเห็น โดยไฟลของ Jupyter นั้นตองมีสวนขยายเปน .ipynb (มาจาก 

Interactive Python Notebook ซึง่เปนชื+อเดิมของ Jupyter) ซึง่แนวทางการสรางไฟลอาจทาํแบบใดแบบหน่ึงคอื

  วิธีที่ 1 เปดเขาสู VS Code แลวทําตามขั้นตอนดังนี้

1) เลือกเมนู File > New File... (ตองเปนเมนู New File อันที่สอง ไมใชอันบนสุด) หรือคลิกที่ลิงก 

New File... บนหนาจอ Welcome (Get Started) ก็ได

2) เลือกชนิดไฟลเปน Jupyter Notebook

1
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3) หลงัจากน้ัน จะเขาสูมมุมองของ Jupyter ซึง่ไฟลจะถกูกาํหนดชื+อเปน Untitled-x.ipynb ไวลวงหนา

4) หากตองการบันทึกไฟล ใหเลือกเมนู File > Save (หรือ Save As) แลวกําหนดชื+อใหมลงไป โดย

สวนขยายของไฟลตองเปน .ipynb เทานั้น เชน test.ipynb และเลือกจัดเก็บไวที่ใดก็ได ซึ่งตาม

การอางอิงในหนังสือเลมนี้ผูเขียนจะเก็บไวที่ C:\python

  วิธีที่ 2 เขาสู VS Code แลวเปดโฟลเดอรที่จะจัดเก็บไฟล Jupyter (ถายังไมมีโฟลเดอรดังกลาว

ตองสรางข้ึนมากอน)  เชนในหนงัสอืเลมนี ้ผูเขยีนจะเปดโฟลเดอรทีต่าํแหน�ง C:\python หลังจากนัน้ 

ใหทําดังนี้

1) ใหคลิกไอคอน New File

2) กําหนดชื+อไฟลตามตองการ โดยใหมีสวนขยายเปน .ipynb โดยไฟลจะถูกจัดเก็บลงในโฟลเดอร

ที่เรากําลังเปดในขณะนั้น

3) เมื+อเราคลกิเปดไฟลทีม่สีวนขยายเปน .ipynb 

สวน Editor ของ VS Code กจ็ะแสดงเครื+องมือ 

ในมุมมองของ Jupyter โดยอัตโนมัติ

การใชงานในครั้งตอไป เราอาจเปดไฟล .ipynb โดยตรง เชน เลือกเมนู File > Open File หรือจะเปด

โฟลเดอรทีจ่ดัเกบ็ไฟลเอาไว เชน เลอืกเมนู File > Open Folder แลวคอยเปดไฟล .ipynb ภายใน VS Code กไ็ด
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การใชเครื&องมือของ Jupyter
เราตองเปดไฟล ที่มีสวนขยายเปน .ipynb เครื+องมือของ Jupyter จึงจะปรากฏใหเห็น ดังที่ไดกลาวไป

ในหัวขอที่ผานมา สําหรับแนวทางการใชเครื+องมือที่สําคัญของ Jupyter มีดังนี้

การเขียนโคดและการรัน
เมื+อเราสรางหรือเปดไฟลของ Jupyter ตอไปก็สามารถเขียนโคดภาษาไพธอนลงในเซลลไดตามปกติ 

และหากตองการรัน ใหคลิกไอคอนหัวลูกศรท่ีขอบดานซายของเซลลนั้น แลวผลลัพธที่ได จะถูกนํามาแสดงที่

ดานลางของเซลล

นอกจากนี้ ยังมีทางเลือกอื+น ๆ  ในการรัน เชน กดคียบอรดปุม <Ctrl + Alt + Enter> เพื+อรันเซลลที่ถูก

เลือกในขณะนั้น (ตองคลิกที่เซลลใหอยูในสถานะ Active ซึ่งเสนขอบจะเปนสีฟา)

การเพิ่มและลบเซลล
หากเราตองการเพิ่มเซลลใหมเพื+อทดสอบโคดของเรื+องอื+น ๆ  ความจริงก็มีหลายทางเลือกที่ทําได แตวิธี

ที่น�าจะสะดวกที่สุดอาจเลือกอยางใดอยางหนึ่งดังนี้

  วิธีที่ 1 คลิกที่ปุม + Code ที่แถบทูลบารดานบน (ซายสุด) ซึ่งในกรณีนี้จะเปนการเพิ่มเซลลใหม

ตอจากเซลลที่ถูกเลือกในขณะนั้น หรือถาไมเลือกเซลลใดเลยก็จะเพิ่มตอจากเซลลแรก

  วิธีที่ 2 เมื+อตองการเพิม่เซลลทีต่าํแหน�งใด ใหเลื+อนเมาสมายงับรเิวณกึง่กลางหนาจอของตาํแหน�ง

นั้น เมื+อปรากฏปุม + Code ก็ใหคลิกปุมดังกลาว ซึ่งเซลลจะถูกเพิ่มที่นั่น
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หากเราตองการลบเซลลใดทิง้ไป ใหเลอืก (คลกิ) ทีเ่ซลลนัน้กอน เพื+อใหอยูในสถานะ Active ซึง่จะปรากฏ

แถบทูลบารที่มุมขวาบน แลวคลิกปุมไอคอนถังขยะ

การนําโคดของหนังสือมาใชงาน
เราไดทราบไปแลววา ภายในไฟล .ipynb ของ Jupyter อาจมีไดมากกวา 1 เซลล แตหากในไฟลเดยีวกนั

มจีาํนวนเซลลมากเกนิไป ก็อาจยุงยากตอการเลื+อนคนหาเมื+อตองการทดสอบในภายหลัง ดงันัน้ ในหนงัสอืเลมนี้ 

จึงจะแยกโคดของแตละบทใหอยูคนละไฟล เชน 

chapter2.ipynb สําหรับโคดตัวอยางทั้งหมดของบทที่ 2

chapter3.ipynb สําหรับโคดตัวอยางทั้งหมดของบทที่ 3

...
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ในแตละไฟลนั้น จะประกอบไปดวยเซลลยอย ๆ  สําหรับตัวอยางตาง ๆ  ที่มีในบทนั้น ๆ  ซึ่งจะเขียนกํากับ

เอาไวที่บรรทัดแรกของแตละเซลล และจะตรงกับที่ระบุไวในหนังสือ เชน

สําหรับโคดของหนังสือเลมนี้ ผูอานสามารถดาวนโหลดไดที่ http://www.developerthai.com ทั้งนี้

หากเราจะทดสอบการทํางาน ใหเขาสู VS Code แลวเปดโฟลเดอร python จากนั้นคอยคลิกเปดไฟลของบทที่

ตองการ ตอไปก็สามารถรันทดสอบตามหลักการที่ไดกลาวมาแลวทั้งหมด





ภ
 าษาไพธอนมอีงคประกอบและขอกําหนดทีส่าํคญัหลายอยางซึง่เราควรรูจกัในเบือ้งตน โดยสิง่ทีจ่ะกลาวถงึ 

 ในบทนี ้เชน การประกาศและกาํหนดคาตวัแปร การแสดงผล ขอมลูชนดิตวัเลขและสตริง รวมถงึการรบั 

ขอมูลทางคียบอรด ซึ่งสิ่งเหลานี้ลวนเปนพื้นฐานสําคัญของภาษาไพธอนที่เราตองใชงานกันไปตลอด

คียเวิรดของภาษา Python
คียเวิรด (Keyword) หรือ Reserved Words คือคําที่ถูกสงวนไวเปนคําสั่งสําหรับควบคุมการทํางาน  

ซึ่งเราไมสามารถนําคําเหลานี้ไปตั้งเปนชื+อตัวแปรหรือฟงกชันได โดยคียเวิรดทั้งหมดของไพธอนมีดังนี้

False await else import pass

None break except in raise

True class finally is return

and continue for lambda try

as def from nonlocal while

assert del global not with

async elif if or yield

พื้นฐานการเขียนโคด  
Python

2
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คาํวา True, False และ None ตองเขยีนขึน้ตนดวยตวัพมิพใหญ เพราะไมไดใชเพื+อเปนคาํส่ัง แตใชแทน

คาของขอมูล สวนคําอื+น ๆ  ตองเขียนเปนตัวพิมพเล็กทั้งหมด อยางไรก็ตาม ในอนาคตอาจมีการเพิ่มคียเวิรดเขา

มาใหมก็เปนได ซึ่งเราสามารถเขียนโคดเพื+อแสดงคียเวิรดทั้งหมดของเวอรชันที่ใชงานอยูในขณะนั้น เชน อาจ

เขียนคําสั่งลงในเซลลของ Jupyter ดังนี้

ตัวอยาง  2 -1  แสดงคียเวิรดทั้งหมดของภาษาไพธอน

import keyword
print(keyword.kwlist)

ถาเราไมแน�ใจวาคํานั้นเปนคียเวิรดของไพธอนหรือไม ก็สามารถตรวจสอบดวยคําสั่งดังนี้

keyword.iskeyword("คําที่จะตรวจสอบ")

ถาเปนคียเวิรดจะไดคําวา True กลับคืนมา แตถาไมใชจะไดคําวา False เชน
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ตัวอยาง  2 -2  การตรวจสอบวาเปนคียเวิรดของภาษาไพธอนหรือไม

import keyword

p = keyword.iskeyword("python")
print(p)

a = keyword.iskeyword("and")
print(a)

ลักษณะของตัวแปร
ตัวแปร (Variable) หมายถึงคําที่เราใชสําหรับอางอิงถึงขอมูลตาง ๆ  ทั้งการจัดเก็บและการนําขอมูลไป 

ใชงาน จะตองทําผานตัวแปร ซึ่งการตั้งชื+อตัวแปรในไพธอน มีขอกําหนดดังนี้

 ตองประกอบดวยตัว a - z หรือ A - Z หรือ Underscore (_) หรือตัวเลข 0 - 9 เทานั้น

 หามขึ้นตน (อักขระตัวแรก) ดวยตัวเลข แตตัวตอ ๆ  ไปสามารถใชเปนตัวเลขได

 หามมีชองวางหรืออักขระอื+นใดนอกเหนือจาก 2 ขอที่กลาวมา

 การเขียนดวยตัวพิมพเล็ก-ใหญตางกัน เชน abc, ABC, Abc ถือวาไมเหมือนกัน

 ตองไมซํ้ากับคียเวิรดของภาษาไพธอน

 ในภาษาไพธอน เรานิยมตั้งชื+อตัวแปรใหขึ้นตนดวยตัวพิมพเล็ก แตถาเปนการนําหลาย ๆ  คํามารวม

กันเปนชื+อตัวแปร ก็อาจใชรูปแบบอยางใดอยางหนึ่งคือ

 ๏ คั่นแตละคําดวยเครื+องหมาย Underscore (_) เชน max_value, is_first_time

 ๏ หรืออาจเขียนติดกัน โดยใหอักขระตัวแรกของแตละคําเปนตัวพิมพใหญ ยกเวนคําแรก เชน 

numProducts, isValidInput, numDaysOfMonth

 ตัวอยาง การตั้งชื+อตัวแปรที่ถูกตอง

 ๏ x

 ๏ value

 ๏ firstname

 ๏ pricePerUnit

 ๏ num1

 ๏ grand_total

 ๏ freeDiskSpace

 ๏ string2number

 ๏ v3_beta2

 ๏ core_i_7

 ๏ _x x_

 ๏ _x_
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 ลักษณะการตั้งชื+อตัวแปรที่ ไมถูกตอง

 ๏ price$ เพราะมีอักขระ $

 ๏ 3x เพราะเริ่มตนดวยตัวเลข

 ๏ class เพราะซํ้ากับคียเวิรด

 ๏ lucky number เพราะมีชองวาง

การกําหนดคาใหกับตัวแปร
ในภาษาไพธอน เราจะประกาศตัวแปรพรอมกบักาํหนดคาอยางใดอยางหนึง่ใหกบัมันทนัท ีโดยไมตองระบุ

ชนดิขอมลู และไมใชคยีเวริดอื+นใดเพื+อบงชีว้าเปนตวัแปรเหมอืนทีต่องทาํในภาษาอื+น ๆ  ซึง่รปูแบบโดยทัว่ไปของ

การสรางและกําหนดคาตัวแปรในภาษาไพธอนคือ

ชื+อตัวแปร = คาที่กําหนด

สาํหรับชื+อตวัแปร กใ็ชหลกัการตามท่ีไดกลาวไวในหัวขอทีแ่ลว สวนการกาํหนดคาใหกบัตวัแปร มีหลกัการ 

พื้นฐานทั่วไปคือ

 เราตองประกาศตัวแปรพรอมกําหนดคาอยางใดอยางหนึ่งใหมัน ในลักษณะดังนี้

x = คาที่กําหนด กําหนดคาใหกับมันทันทีที่ประกาศตัวแปร

y = คาที่กําหนด กําหนดคาใหกับมันทันทีที่ประกาศตัวแปร

a = x นําคาของตัวแปร x มากําหนดใหแกตัวแปร a (ตองมี x อยูกอนแลว)

b = x + y ตัวแปร b มีคาเทากับผลบวกของ x กับ y (ตองมี x และ y อยูกอนแลว)

 หากประกาศเพียงชื+อ หรือประกาศแลวไปกําหนดคาภายหลัง จะเกิดขอผิดพลาด

x ผิด เพราะกําหนดแคชื+อตัวแปร

a

a = คาที่กําหนด

ผิด เพราะตอนแรกระบุแคชื+อตัวแปร แมจะกําหนดคาในภายหลังก็ตาม

 ตัวแปรที่กําหนดคาใหกับมันเอาไวแลว สามารถเปลี่ยนแปลงคาในภายหลังได เชน

number = คาที ่1
number = คาที ่2
number = คาที ่3
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 ตามปกตนิัน้ คาทีก่าํหนดใหแกตวัแปร รวมทัง้เครื+องหมาย = ตองเขยีนในบรรทดัเดียวกบัตวัแปร แต

ถาจาํเปนตองเลื+อนคาทีจ่ะกาํหนดใหกบัมัน หรือเครื+องหมาย = ไปไวทีบ่รรทดัถดัไป ใหวางเครื+องหมาย 

Backslash (\) ตอทายตัวแปร หรือตอทายเครื+องหมาย = จากนั้นก็นําสวนที่เหลือไปเขียนที่บรรทัด

ถัดไปไดเลย เชน ลองเปรียบเทียบลักษณะการเขียนโคดที่ผิดและถูกตองดังตอไปนี้

 ๏ ลักษณะการเขียนที่ ผิด

number = 
 คาที่กําหนด

 ๏ ลักษณะการเขียนที่ ถูกตอง

number = \
 คาที่กําหนด

 นอกจากน้ี เราสามารถกําหนดคาใหแกตัวแปรหลายตัว ๆ  พรอมกัน โดยการเขียนคําสั่งในบรรทัด

เดียวกันดวยรูปแบบดังตอไปนี้

ตัวแปร1, ตัวแปร2, ตัวแปร3, ... = คาตัวแปร1, คาตัวแปร2, คาตัวแปร3, ...

การกําหนดขอมูลชนิดตัวเลข
การกําหนดขอมูลชนิดตัวเลขใหกับตัวแปร มีหลักการขั้นพื้นฐานคือ

 การกําหนดคาที่เปนขอมูลชนิดตัวเลขไมวาจะเปนจํานวนเต็มหรือทศนิยมก็ตาม สามารถระบุตัวเลข

ลงไปไดเลย เพราะตามปกติเราจะเขียนตัวเลขติดกันอยูแลว เชน

x = 123 จํานวนเต็ม

y = 456.789 เลขทศนิยม

a = -10 จํานวนเต็มติดลบ
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b = -20.25 เลขทศนิยมและติดลบ

c, d = 5, 15 c = 5 และ d = 15

 เนื+องจากภาษาไพธอนไมยดึตดิกบัชนิดขอมลู ดงันัน้ เราสามารถเปล่ียนคาของตวัแปรจากจาํนวนเต็ม

เปนทศนิยม หรือจากทศนิยมเปนจํานวนเต็ม โดยไมเกิดขอผิดพลาด เชน

x = 123

x = 4.56

เดิมเปนจํานวนเต็ม แลวเปลี่ยนเปนเลขทศนิยม

y = 7.11

y = 101

เดิมเปนเลขทศนิยม แลวเปลี่ยนเปนจํานวนเต็ม

 การเขียนตัวเลขนั้น เรา ไม สามารถใชเครื+องหมาย , เพื+อคั่นหลักพันได แตในภาษาไพธอน อนุญาต

ใหเราใสเครื+องหมาย Underscore (_) แทรกลงไประหวางตัวเลขเพื+อใหอานงายขึ้น โดยสามารถนํา

คานั้นไปคํานวณไดตามปกติ ซึ่งขอกําหนดที่สําคัญคือ

 ๏ สามารถเขียน _ แทรกไวระหวางตัวเลขไดทั้งสวนจํานวนเต็มและทศนิยม

 ๏ ไมจําเปนตองใชคั่นหลักพัน แตคั่นระหวางตัวเลขที่หลักใด ๆ  ก็ได

 ๏ หามเขียนเครื+องหมาย _ ตอเนื+องกันตั้งแต 2 อันขึ้นไป

 ๏ หามใชเปนตัวขึ้นตนและตัวสุดทาย ทั้งสวนจํานวนเต็มและทศนิยม

 ๏ สามารถนําตัวเลขนั้นไปคํานวณไดตามปกติ

 ๏ ถาเราแสดงตัวเลขนั้นออกไป เชน ใชฟงกชัน print( ) จะไมมีเครื+องหมาย _ ปรากฏใหเห็น

x = 1,234 ผิด (ใชเครื+องหมาย , คั่นหลักพันไมได)

a = 1_234_567

print(a)

print(a + 1)

ถูก เขียนแบบนี้ได

1234567

1234568

b = 1_2_3_4 ถูก เขียนแบบนี้ได (ไมจําเปนตองใชคั่นหลักพัน)

c = 1__2___3 ผิด (หามเขียน _ ตอเนื+องกันตั้งแต 2 อันขึ้นไป)

d = _1_2_3 ผิด (หามใช _ เปนตัวขึ้นตน)

e = 1_2_3_ ผิด (หามใช _ เปนตัวสุดทาย)



บทที่ 2   39

f = 123_456.78_9_0

print(f)

ถูก เขียนแบบนี้ได

123456.789

g = 12._3_4_5   ผิด (เพราะสวนทศนิยมขึ้นตนดวย _)

h = 123.456_ ผิด (เพราะสวนทศนิยมลงทายดวย _)

สําหรับรายละเอียดเพิ่มเติมของขอมูลชนิดตัวเลข จะกลาวถึงอีกครั้งในบทที่ 3

การกําหนดขอมูลชนิดสตริง 
สตริง (String) เปนการนําอักขระแตละตัวมาวางเรียงตอกันใหกลายเปนขอความ ซึ่งเราตองกําหนดจุด

เริ่มตนและสิ้นสุดของมันดวยเครื+องหมายคําพูด (Quotes) แบบใดแบบหนึ่งคือ

 Single Quotes (' ')

 Double Quotes (" ") 

 Single Triple Quotes (''' ''') หรือ Double Triple Quotes (""" """) หรือเรียกรวม ๆ  วา Triple 

Quotes

title = "Python Programming"
birthday = 'Happy Birthday'
christmas = '''Merry Christmas'''
new_year = """สวัสดี ปใหม"""
firstname, lastname = 'Tom', "Jerry"

สตริงที่กําหนดดวยเครื+องหมาย " " หรือ ' ' อันเดียวกัน (ไมรวม Triple Quotes) ตองเขียนในบรรทัด

เดียวกันใหครบทั้งหมด หากแยกสตริงที่อยูในเครื+องหมาย " " หรือ ' ' อันเดียวกัน ไปขึ้นบรรทัดใหม จะเกิด

ขอผิดพลาด เชน กรณีตอไปนี้

a = "Python 

Programming"

ผิด เพราะแยกสตริงที่อยูในเครื+องหมาย " " อันเดียวกัน ไปขึ้นบรรทัดใหม

b = 'ไพธอนไมใชงู

แตเปนภาษาคอมพิวเตอร'

ผิด เพราะแยกสตริงที่อยูในเครื+องหมาย ' ' อันเดียวกัน ไปขึ้นบรรทัดใหม

อยางไรก็ตาม หากเปนสตริงที่ยาวมาก จนไมสามารถเขียนใหครบในบรรทัดเดียวกันได ก็มีทางเลือกให

เราสามารถแยกสตริงไปเขียนไวคนละบรรทัดได โดยใชวิธีใดวิธีหนึ่งคือ
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 วิธีที่ 1 หากกําหนดสตริงดวยเครื+องหมาย " " หรือ ' ' ใหแทรกเครื+องหมาย Backslash (\) ตรง

จุดที่จะแยกสตริงไปขึ้นบรรทัดใหม เชน

a = "Python \

Programming"

ถูก หลังจากแทรกเครื+องหมาย \ สามารถแยกสตริงอยูในเครื+องหมาย " " อัน

เดียวกัน ไปขึ้นบรรทัดใหมได 

b = 'ไพธอนไมใชงู \

แตเปนภาษาคอมพิวเตอร'

ถูก เพราะแทรกเครื+องหมาย \ ตรงจุดที่จะขึ้นบรรทัดใหมแลว

 วิธีที่ 2 หากกําหนดดวย Triple Quotes ไมวาจะเปน """ """ หรือ ''' ''' ก็ตาม สามารถแยก

สตริงไปขึ้นบรรทัดใหมไดเลย โดยไมจําเปนตองแทรกเครื+องหมาย \ เชน

a = """Python 

Programming"""

ถูก สามารถแยกสตริงอยูในเครื+องหมาย """ """ อันเดียวกัน ไปขึ้นบรรทัด

ใหมไดเลย

b = '''ไพธอนไมใชงู 

แตเปนภาษาคอมพวิเตอร'''

ถูก การใชเครื+องหมาย ''' ''' สามารถแยกสตริงไปขึ้นบรรทัดใหมไดเลย

การแทรกเครื+องหมาย \ ในสตริงดังที่กลาวมา เปนเพียงการแยกบรรทัดในขั้นตอนการเขียนโคดเทานั้น 

ซึ่งเมื+อนําสตริงไปใชงานอื+นตอไป เครื+องหมาย \ จะไมรวมอยูในสตริง จึงสามารถใชงานไดเชนเดียวกับสตริง

ทั่วไป แตก็มีปญหาอยางหน่ึงที่เราควรคํานึงถึง น่ันก็คือ หากเราแยกสตริงไปขึ้นบรรทัดใหม ไมวาจะเปนการ

แทรกเครื+องหมาย \ ไวในสตรงิ หรอืการใช Triple Quotes กต็าม หากเยือ้งสตริงเขาไป เมื+อเราแสดงผล จะเกิด 

ชองวางระหวางสตริงตามระยะที่เยื้องเขาไป เชน

ตัวอยาง  2 -3  ระยะเยื้องที่เกิดจากการแทรกเครื+องหมาย \

count = \
'One, \
    Two, \
     Three, \
        Four'

print(count)

ถาเราไมตองการใหมีชองวางดังที่กลาวมา อาจใชวิธีการแบงสตริงออกเปนสวนยอย ๆ  ใหอยูใน

เครื+องหมาย " " หรือ ' ' คนละอนั แลวคอยนาํสตรงิเหลานัน้มาเชื+อมตอเขาดวยกนั ดงัทีจ่ะกลาวถงึในหวัขอตอไป
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สําหรับการกําหนดสตริงดวยเครื+องหมาย " " หรือ ' ' นั้น ตามปกติเราจะเลือกใชอะไรก็ได หรือบางครั้ง

อาจใชรวมกัน เชน ถาในสตริงนั้นมีเครื+องหมาย " เปนสวนหนึ่งของมันดวย เราก็ครอบสตริงทั้งหมด (ชั้นนอก) 

ดวย ' ' หรือในทางตรงขาม ถาในสตริงนั้นมีเครื+องหมาย ' เปนสวนหนึ่งของมันดวย เราก็ครอบสตริงทั้งหมด

ดวย " " เชน ลองเปรียบเทียบกรณีตอไปนี้

msg = 'Let's go' ผิด เพราะใชเครื+องหมาย ' ซอนกัน

msg = "Let's go"        ถูก  

str = "She said "Hello"" ผิด เพราะใชเครื+องหมาย " ซอนกัน

str = 'She said "Hello"' ถูก  

อยางไรก็ตาม สําหรับปญหาการเขียนเครื+องหมาย " หรือ ' ไวในสตริง เราอาจแกไขโดยการวาง

เครื+องหมาย Backslash (\) ไวหนา " หรือ ' ที่เปนสวนหนึ่งของสตริง ซึ่งวิธีนี้เราสามารถกําหนดสตริงดวย " 

" หรือ ' ' เพียงอยางใดอยางหนึ่ง โดยไมตองใชสลับกันก็ได เชน

msg = 'Let\'s go' หากแสดงผลจะกลายเปน  Let's go

str = "She said \"Hello\"" หากแสดงผลจะกลายเปน  She said "Hello"

สําหรับรายละเอียดเกี่ยวกับขอมูลชนิดสตริงยังมีอีกมาก ซึ่งเราจะไดเรียนรูเพิ่มเติมทั้งในบทนี้และบท

ตอ ๆ  ไป

การแสดงผลดวยฟงกชัน print( )
เมื+อเราตองการแสดงขอความออกไปท่ีหนาจอ จะกาํหนดดวยฟงกชนั print( ) พรอมระบขุอมลูทีต่องการ

แสดงไวในวงเล็บ ซึ่งที่ผานมานั้น แมเราจะใชฟงกชันนี้มาบางแลว แตยังมีรายละเอียดอีกหลายอยางที่ควรรู

เพิ่มเติมดังตอไปนี้

การใชฟงกชัน print( ) แบบพื้นฐาน
รูปแบบพื้นฐานที่สุดของฟงกชัน print( ) มีลักษณะดังนี้

 print(ขอมูล)
หรือ print(ขอมูล1, ขอมูล2, ขอมูล3, ...)
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 สาํหรับขอมลูทีจ่ะแสดงผล หากเปนขอความ (สตริง) ใหเขยีนไวในเครื+องหมายคาํพดู (Quotes) แบบใด 

แบบหนึ่งดังที่กลาวมาแลว

 หากเปนตัวเลข สามารถเขียนลงไปในวงเล็บไดโดยตรง

 หากจะแสดงคาของตัวแปร ก็ระบุชื+อตัวแปรนั้นลงในวงเล็บไดเลย

 หากเรากําหนดแค print( ) โดยไมระบุขอมูลที่จะแสดง จะเปนการแทรกบรรทัดวาง และถาตองการ

แทรกหลายบรรทัด ก็ระบุ print( ) ตามจํานวนบรรทัดที่ตองการ

ตัวอยาง  2 -4  การใชคําสั่ง print( ) เพื+อแสดงขอมูลชนิดตาง ๆ

print('Hello')
print('สวัสด'ี)
print(123)
print(456.789)
print()   

language = 'Python'
version = 4.0
print(language)
print(version)

 สาํหรบัรูปแบบ print(ขอมลู1, ขอมลู2, ขอมลู3, ...) เปนการแสดงขอมลูมากกวา 1 อยางแบบตอเนื+อง 

ในบรรทัดเดียวกัน โดยใชฟงกชัน print( ) เพียงครั้งเดียว ซึ่งขอมูลเหลานั้นอาจเปนสตริง ตัวเลข 

หรือคาจากตัวแปรก็ได และขอมูลแตละคาจะถูกเวนชองวางใหโดยอัตโนมัติ เชน

ตัวอยาง  2 -5  การแสดงขอมูลหลายคาในคําสั่ง print( ) เดียวกัน

print('Python', 'Programming', 'for', 'Beginner')

a = 'หนึ่ง,'
b = 'สอง,'
c = 'สาม,'
print(a, b, c, 'สี'่)

name = 'Guido van Rossum'
year = 1994
print(name, 
 'สรางภาษาไพธอนในป ค.ศ.', 
 year)
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การใชฟงกชัน print( ) ที่ซับซอนข้ึน
เราสามารถกําหนดลักษณะการแสดงผลเพิ่มเติมใหกับฟงกชัน print( ) โดยใชรูปแบบอยางใดอยางหนึ่ง

ดังนี้

print(ขอมูล1, ขอมูล2, ขอมูล3, ..., sep=...)
print(ขอมูล1, ขอมูล2, ขอมูล3, ..., end=...)
print(ขอมูล1, ขอมูล2, ขอมูล3, ..., sep=..., end=...)

 สําหรับขอมูล 1, 2, 3, ... ก็เหมือนกับรูปแบบในหัวขอที่แลว คือจะมีจํานวนเทาไหรก็ได

 sep และ end เปนการระบุออปชนัเพิม่เตมิใหกบัฟงกชนั โดยลกัษณะเชนนีใ้นภาษาไพธอนจะเรียกวา 

Keyword Argument (หรือเรียกสั้น ๆ  วา คียเวิรด) แตเปนคนละกรณีกับ Keyword หรือ Reserved 

Word ที่เปนคําสงวนของไพธอน ซึ่งเราจะไดศึกษารายละเอียดเรื+องนี้ในบทที่ 10

 sep (มาจาก separator) คอืสิง่ทีจ่ะใชคัน่ระหวางขอมลูแตละอนั โดยคาทีก่าํหนดใหแก sep ตองเปน 

สตริงเทานั้น (อยูในเครื+องหมายคําพูดแบบใดแบบหนึ่ง) ซึ่งตามปกติ (ไมระบุ sep) จะเปนชองวาง 

1 ชอง

 end คือสิ่งที่จะเขียนตอทายสตริง และตองกําหนดในแบบสตริงเชนเดียวกับ sep โดยตามปกติ (ถา

ไมระบ ุend) จะเปน '\n' ซ่ึงเปนสญัลกัษณสาํหรับการขึน้บรรทดัใหม (รายละเอียดอยูในหวัขอถดัไป)  

แตถาตองการใหฟงกชัน print( ) ถัดไป แสดงผลในบรรทัดเดียวกับฟงกชัน print( ) ปจจุบัน ให

กําหนดคาเปน end='' 

 อาจกําหนด sep และ end เพียงอยางใดอยางหนึ่ง หรือกําหนดทั้งคู หรือไมมีเลยก็ได

ตัวอยาง  2 -6  การใชออปชัน sep และ end ของคําสั่ง print( )

a = 'One'
b = 'Two'
c = 'Three'
d = 'Four'
print(a, b, c, d, sep=', ')

a = 'www'
b = 'developerthai'
c = 'com'
print(a, b, c, sep='.')
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d = 1
m = 'กรกฎาคม'
y = 2565
print('ออกเดินทางในวันที:่ ', end='')
print(d, m, y, sep=' ')

h = 12
m = 34
print('เวลา: ', end='')
print(h, m, sep=':')

ลักษณะพื้นฐานของสตริงที่ควรรูเพิ่มเติม
เนื+องจากสตริง เปนชนิดขอมลูพืน้ฐานสําคัญทีเ่ราตองนาํไปใชกนัอยูตลอด ดงันัน้จงึมรีายละเอียดปลกียอย 

คอนขางมาก โดยในหัวขอนี้ จะกลาวถึงลักษณะพื้นฐานบางอยางเกี่ยวกับสตริงที่เราควรรูจักเพิ่มเติม ซึ่งตองใช

รวมกับเนื้อหาของเรื+องตอ ๆ  ไป สวนรูปแบบการใชงานอื+น ๆ  จะกลาวถึงอีกครั้งในบทที่ 8

การเชื&อมตอสตริง
การเชื+อมตอสตรงิ (String Concatenation) เปนการนาํสตริงยอย ๆ  มารวมเขาดวยกนั โดยใชเครื+องหมาย 

+ เพื+อใหกลายเปนสตริงอันเดียวกัน รวมถึงการนําคาจากตัวแปรมารวมกับสตริงอีกดวย เชน

ตัวอยาง  2 -7  การเชื+อมตอสตริงดวยเครื+องหมาย +

str1 = 'ขอเชิญหมายเลข ' + ' สามสิบ ' + ' ที่ชองบริการ' + ' หา ' + 'คะ'
print(str1)

name = 'Guido van Rossum'
str2 = 'ผูสรางภาษาไพธอนคือ ' + name + ' เมื+อป 1994'
print(str2)

name = "Malee"
country = "Thailand"
print("My name is " + name + 
  " from " + country)

อยางไรก็ตาม ในภาษาไพธอนนั้น ไมสามารถใชเครื+องหมาย + เพื+อเชื+อมตอระหวางสตริงกับตัวเลข

โดยตรงได เชน กรณีตอไปนี้ จะเกิดขอผิดพลาดทั้งหมด




